We support IE11 and above and the recent Chrome, Safari, and Firefox.

Did this answer your question?